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Neste laboratdrio, iremos investigar o protocolo IP, focando o datagrama IP. Vamos fazé-lo
através da analise de um trace de datagramas IP enviados e recebidos por uma execugao do
programa traceroute (o programa Traceroute sera explorado em mais detalhe no Ethereal
ICMP laboratério). Nés vamos investigar os varios campos no datagrama IP estudar a
fragmentagédo em detalhe.

Antes de iniciar este laboratério, vocé provavelmente vai querer rever o item 1.63 no texto e
o item 3.4 da RFC 2151 [ftp://ftp.rfc-editor.org/in-notes/rfc2151.txt] para atualizar-se sobre o
funcionamento do programa traceroute. Vocé também vai querer ler o item 4,4 do texto, e
provavelmente também ter a RFC 791 [ftp://ftp.rfc-editor.org/in-notes/rfc791.txt] a
mé&o, para uma discussdo do protocolo IP.’

1. Capturando pacotes a partir da execucio do traceroute

A fim de gerar um trace de datagramas IP para este laboratério, vamos usar o programa
traceroute para enviar datagramas de tamanhos diferentes para algum destino, X. Lembre-se
que traceroute funciona através do envio de um ou mais datagramas com o time-to-live
(TTL) no cabecalho IP definido como 1, seguido do envio de outras séries de datagramas com
TTL=2, 3, 4 e assim por diante. Lembre-se que em cada roteador que o datagrama alcanca o
TTL é decrementado em 1 (na verdade, a RFC 791 diz que o roteador deve diminuir o TTL de
pelo menos um). Se o TTL que chega estiver em 0 (zero), o router volta uma mensagem ICMP
(tipo 11 - TTL excedido) para o host que originou o datagrama. Como resultado deste
comportamento, um datagrama enviado com um TTL=1 (enviado pelo host executando
traceroute) a um host distante, sera decrementado em 1 no roteador local (préximo) e
provocara o envio da mensagem ICMP TTL excedido de volta para o remetente, o datagrama
enviado com um TTL=2 fara com que o segundo roteador (dois saltos) envie uma mensagem
ICMP para o remetente, o datagrama enviado com um TTL=3 fara com que terceiro roteador
(trés saltos) envie uma mensagem ICMP para o remetente, e assim por diante. Desta forma, o
host executando traceroute pode aprender as identidades dos roteadores entre entre sua rede
e a rede do host destino X, olhando para os enderecos IP de origem no datagramas contendo
as mensagens ICMP de TTL excedido.

Queremos executar o traceroute para enviar datagramas de varios comprimentos. Assim:

No Windows: O programa tracert usado com o Windows n&o permite alterar o tamanho do echo
request ICMP, mensagem PING, enviada pelo programa tracert (usado para o0 nosso
laboratério Ethereal ICMP). Uma bom programa traceroute, em Windows, é o pingplotter,
disponivel na versao gratuita em http://www.pingplotter.com. Baixe e instale pingplotter, para
testa-lo realizando traceroutes para os seus sites favoritos.

1 Todas as referéncias ao texto neste laboratério sdo a Computer Networking: A Top-down Approach Featuring the
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O tamanho da mensagem ICMP echo request pode ser explicitamente definida no pingplotter
selecionando o item de menu Edit-> Advanced Options-> Packet Options e, em seguida,
preenchendo o tamanho do camo Packet Size O tamanho do pacote padrédo é 56 bytes. Entdo
pingplotter enviara uma série de pacotes com valores TTL incrementados de um. Ele reiniciara
0 processo de envio de novo com um TTL=1, depois de esperar uma quantidade de Traces em
um intervalo de tempo. O valor do Intervalo entre Traces e o numero de intervalos podem ser
explicitamente definidos em pingplotter.

No Linux / Unix: Com o comando traceroute do Unix, o tamanho do datagrama UDP enviado
para o destino pode ser explicitamente definido, indicando o numero de bytes do datagrama na
linha de comando do traceroute imediatamente apdés o nome ou do endereco do destino. Por
exemplo, para enviar no traceroute com datagramas de 2000 bytes para gaia.cs.umass.edu, o
comando seria:

% traceroute gaia.cs.umass.edu 2000

Faca o seguinte:

* No Ethereal inicie a captura de pacotes (Capture-> Start) e pressione OK na tela de opgdes
Ethereal Packet Capture (ndo precisa selecionar todas as opgdes aqui)

» Se vocé estiver usando uma plataforma Windows, inicie pingplotter e introduza um nome de
um destino alvo no campo "Address to Trace". Digite 3 no campo "# of times to trace”, assim
vocé ndo coletara muitos dados. Selecione o item de menu Edit -> Advanced Options-> Packet
Options e introduza um valor de 56 no campo Packet Size e pressione OK. Em seguida,
pressione o botdo Resume. Vocé devera ver uma janela pingplotter parecida com esta:

#: gaia.cs.umass.edu - Ping Plotter - |EI|1|
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Em seguida, enviar um conjunto de datagramas com um comprimento maior, escolhendo Edit->
Advanced Options-> Packet Options e introduza um valor de 2000 bytes no campo de Packet
Size e pressione OK. Em seguida, pressione o botdo Resume.

Finalmente, envie um conjunto de datagramas com um comprimento maior, escolhendo Edit->
Advanced Options-> Packet Options e introduzindo um valor de 3500 no campo de Packet Size
e pressionando OK Em seguida, pressione o botdo Resume.

Pare o rastreamento Ethereal.

Se vocé estiver usando uma plataforma Unix, digite trés comandos traceroute, sendo um com



comprimento de 56 bytes, um com comprimento de 2000 bytes e um com comprimento de
3500 bytes.

Pare o rastreamento Ethereal.

Se vocé ndo conseguir executar o Ethereal numa rede conectada, vocé pode baixar o arquivo
de rastreamento de pacotes que foi capturado quando o autor estava seguindo 0s passos
acima, em seu computador Windows?. Vocé pode usar o trace do autor ou o seu proprio trace,
quando voceé for explorar as perguntas abaixo.

2. Um olhar sobre o trace capturado

Em seu trace, vocé deve ser capaz de ver a série de mensagens ICMP Echo Request (no caso
de Maquina Windows) ou o segmento UDP (no caso do Unix), enviado pelo seu computador e
as mensagens ICMP TTL exceeded retornadas ao seu computador pelos roteadores. Nas
perguntas abaixo, vamos supor que vocé estd usando uma maquina Windows, as questdes
correspondentes para o caso de uma maquina Unix devem ser idénticas. Sempre que possivel,
ao responder uma pergunta entregue uma copia impressa do trace de pacote (s) que vocé
usou para responder. Sobre a impresséo explique sua resposta. Para imprimir um pacote, use
File-> Print, escolha Selected packet only, escolha Packet summary line, e selecione a
quantidade minima de detalhes do pacote que vocé precisa para responder a pergunta.

1. Selecione a primeira mensagem ICMP Echo Request enviada pelo seu computador, e
expanda o pacote do Protocolo Internet na janela de detalhes do pacote.

{@ ip-ethereal-lab-trace-1 - Ethereal - Dlﬂ

File Edt ‘“ew Go Capture  Analyze  Statistics  Help

B EE*x®8 Res T L QA BPOHHEX ©

@Eﬂter: ” j % Expression. .. ‘ hgear’ V app\y|
Mo, - | Time | Source ‘ Destinatian | Protocal | Infio ﬂ
1 0.000000 Telebit_73:8d:ice  Broadcast ARF who has 1%2.168.1.1177 Tell 1%2.168.1.104
2 4.866867 102.168.1.100 152.168.1.1 S5DP M-SEARCH % HTTR/1.1
3 4.868147 192.168.1.100 152.168.1.1 SSDP M-SEARCH % HTTP/1.1
4 5.363336 1092,168.1.100 1592.168.1.1 SSDP M-SEARCH * HTTR/1.1
5 5.36479% 102,168.1.100 1592.168.1.1 SSDP M-SEARCH * HTTR/L.1
6 5.864428 102.168.1.100 152.168.1.1 S5DP M-SEARCH % HTTR/1.1
7 5.885481 192.168.1.100 152.168.1.1 SSDP M-SEARCH % HTTP/L.1
8 6.163045 192.168.1.102 128.59.23.100 1cmMP  Echo Cpingd reguest
L 10.2 1 162.168.1.102 Time-to-|ive axceadead
10 6.18862% 102.168.1.102 128,59, 23,100 ICMP Echo (ping) reguest
11 6.202957 24.218.0.15%3 152.168.1.102 ICMP Time-to-1iwve exceeded
12 6.208597 192.168.1.102 128.59.23.100 ICMP echo (ping) request
13 6.234505 24.128.150,157 152.168.1.102 IMP Time-to-live exceeded
14 6.238605 102.168.1.102 128,59, 23,100 ICMP  Echo (ping) reguest
15 6.257672  24.128.0.101 152.168.1.102 ICMP Time-to-1iwve exceeded
16 6.258750 192.168.1.102 128.59.23.100 ICMP Echo (ping) request ﬂ

[ Frame 9 (70 bytes on wire, 70 bytes captured)
I Ethernet II, src: 00:06:25:da:at:73, DsT: 00:20:e0:8a:70:1a
> Internet Protocol, src cr: 2 1), DsT addr: 192.168.1.102 (192.168.1.102)

wversion: 4

Header Tength: 20 bytes

pifferentiated services Field: OxcO (DsCP 0x30: Class selector &; ECH: 0x00)
Total Length: 56

Identification: 0x9d7c (40316)

Flags: O0x00

Fragment offset: 0

Time to Tive: 255

Protocol: ICMP (0x0L1)

Header checksum: 0OxGcald (correct)

Source: 10.216.228.1 (10.216.228.1)
pestination: 192.168.1.102 (192.168.1.102)
[ Internet Control Message Protocol

-

-

Q000 i
0010 6C ed 0L

Qoz0 00 00 45 00 Q0 34 32 dO
0030 0L 01 f& 16 c0 a8 01 6& B0 3hb 17 &4 OB 00

a0
0040 f7 ca 03 00 50 03

[irternet Protocol {ip), 20 bytes P a0 0 a0 s 0

% Baixe 0 arquivo zip http://gaia.cs.umass.edu/ethereal-labs/ethereal-traces.zip e extraia o
arquivo ip-ethereal-trace-1. Os traces deste arquivo zip foram coletados pelo Ethereal rodando
em um dos computadores do autor, quando executava os passos indicados neste laboratério
Ethereal. Depois de ter baixado o arquivo trace, vocé pode carrega-lo no Ethereal e visualizar o
rastreamento usando o menu suspenso, Abrir e, em seguida selecionando o arquivo de
rastreamento ip-ethereal-trace-1.



http://gaia.cs.umass.edu/ethereal-labs/ethereal-traces.zip

Qual é o endereco IP do seu computador?

2. Dentro do cabegalho do pacote IP, qual € o valor no campo do protocolo da camada
superior?

3. Quantos bytes possui o cabegalho IP?
Quantos bytes possui 0 campo de dados da Datagrama IP?

Explique como vocé determinou o nimero de bytes de do campo de dados (Pay load -
carga util).

4. Esse datagrama IP foi fragmentado?
Explique como vocé determinou se o datagrama foi fragmentado ou néo.

Em seguida, classificar os pacotes tragado de acordo com o enderego IP de origem,
clicando na coluna do cabegalho Source; uma pequena seta apontando para baixo deve
aparecer ao lado da palavra Source. Se a seta aponta para cima, clique na coluna do
cabegalho Source novamente. Selecione a primeira mensagem ICMP Echo Request
enviada pelo seu computador, e expanda as informagdes do Protocolo Internet na janela
"details of selected packet header”. Na janela "listagem de pacotes capturados", vocé vera
todas as mensagens ICMP subseqientes (talvez com pacotes adicionais, enviados por
outros protocolos em execugao no seu computador, intercalados). Use a seta para baixo
para mover através das mensagens ICMP enviadas pelo seu computador.

5. Quais os campos no datagrama IP que mudam sempre de um datagrama para o
préximo dentro dessa série de mensagens ICMP enviadas pelo seu computador?

6. Quais os campos permanecem constantes?

Qual dos campos devem permanecer constante?

Quais os campos deve mudar?

7. Descreva o padrao que vocé vé nos valores no campo Identification do datagrama IP.
Em seguida, com os pacotes ainda ordenadas por endereco de origem, encontre a série de
ICMP TTLexceeded enviados como respostas para o computador pelo roteador mais
préximo (primeiro salto).

8. Quais sado os valores dos campos ldentificagcdo e TTL?

9. Sera que esses valores permanecem inalterados para todas as respostas ICMP - TTL
excedido enviadas para o seu computador pelo roteador mais proximo (primeiro salto)? .

Por qué?

Fragmentacao

Ordenar a listagem de pacotes de acordo com o tempo novamente, clicando na coluna
Time.

10. Encontre a primeira mensagem ICMP Echo Request que foi enviada por seu
computador apds vocé ter alterado o tamanho do pacote em pingplotter para 2000. A
mensagem foi fragmentada em mais de um datagrama IP? [Nota: se vocé n&o encontrar
um pacote que foi fragmentado, vocé deve baixar o arquivo zip http://gaia.cs.umass.edu
/ethereal-labs/ethereal-traces.zip e extrair o rastreamento ip-ethereal-trace-1. Se o seu




computador tem uma interface Ethernet, um pacote tamanho de 2000 deve causar
fragmentation.s]

11. Imprima o primeiro fragmento do datagrama IP fragmentado. Quais sdo as informagdes
no cabecalho do IP que indicam que o datagrama foi fragmentado?

Quais sédo as informagdes no cabegalho do IP que indicam se este é o primeiro fragmento,
um fragmento intermediario ou o Ultimo fragmento?

Qual o tamanho desse datagrama IP?

12. Imprima o segundo fragmento do datagrama IP fragmentado. Quais séo as informacdes
no cabecalho do IP que indicam que esse ndo é o primeiro fragmento do datagrama?

Existem mais fragmentos?

Como vocé pode explicar?

13. Que campos se alteram no cabegalho do IP entre o primeiro e segundo fragmento?

Agora, localize a primeira mensagem ICMP Echo Request que foi enviado por seu
computador depois que vocé mudou o tamanho do pacote em pingplotter para 3500.

14. Como muitos fragmentos foram criados a partir do datagrama original?

15. Quais campos mudaram no cabecalho IP entre os fragmentos?

3 Os pacotes no arquivo zip ip-ethereal-trace-1 rastreado s em http://gaia.cs.umass.edu/ethereal-
labs/etherealtraces s&o todos menores que1500 bytes. Isso ocorre porque o computador no qual o trace foi
recolhida tem uma Placa Ethernet, que limita o tamanho dos pacotes IP ao maximo de 1500 bytes (40 bytes do
cabecalho TCP / IP e 1460 bytes de dados na carga util do protocolo da camada superior). Este valor de 1500
bytes é o padrédo de comprimento maximo permitido pela Ethernet. Se o seu trace indicar um datagrama maior
que 1500 bytes, e o seu computador esta usando uma conexao Ethernet, entdo Ethereal esta relatando o
comprimento do datagrama IP errado, ou provavelmente mostrando apenas uma grande datagrama IP ao invés
de varios pequenos datagramas .. Esta inconsisténcia no relato de comprimentos é devido a interagéo entre o
driver Ethernet e o software Ethereal. Recomendamos que se vocé tiver essa incoeréncia, executar este
laboratério utilizando o arquivo de rastreamento ip-ethereal-trace-1.
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